1979 KZ750B4 Non-start

Home Forums All Things 750 Twin Technical Garage 1979 KZ750B4 Non-start

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #5954
    stuartbuckle
    Participant

    It could be that the starter is drawing to much current causing the voltage to drop causing weak or no spark, it would only happen when the plugs are in and there is compression, bikes like the early Honda GL1000 and cars like Vauxhall Viva used 8volt coils with an inline resister which was bypassed when the starter button was pressed sending a full 12volts to the 8volt coils to help starting.
    I may be wrong as I have not looked but I dont think there is any such system on KZs.
    Charge the battery and then try again only using the kickstart.

    #13064
    stuartbuckle
    Participant

    My 1979 KZ7650 B4 was off the road for a few months so, armed with a new battery and fresh fuel, I tried to start it. It fired up and ran for about 4 seconds, then cut out and hasn’t made a sound since.

    It will crank over, there is a spark at both plugs (they are new), I removed and checked both carb float bowls, lovely and clean and no contaminants, checked the points and ignition timing, all OK.

    I’ve even removed the air filter and tried some Easy-Start. It didn’t do what it said on the tin.

    I am starting to suspect that the ignition coil may be weak and that the plugs may not spark under compression (it has two good compressions).

    Do these have a problem with coils?

    #13065
    stuartbuckle
    Participant

    The 7650 was caused by fat fingers. Of course, it is a KZ750 B4.

    #13057
    lonesome
    Spectator

    Were the float bowls lovely, clean and full? 4 secs is about the time it’ll run with the fuel tap off. I’m not saying yours was off, but a blockage maybe?

    Also, with a sulky Twin, the kickstart is the only way to go. If you happen to have one of the few remaining working electric starts, keep it that way by using it as little as possible!

    #13066
    stuartbuckle
    Participant

    Yes, the float bowls were both full.

    The carbs were ultrasonically cleaned last year and they were drained before storage. The tank was resprayed last year, so that had been drained as well.

    It had fresh fuel in it for the start-up.

    It fired and ran for about four or five seconds and then cut out. I thought that maybe I moved the throttle slightly and that had caused it to stop, but it hasn’t fired since.

    I have tried every combination of choke (sorry, enrichment device) and throttle, but it won’t even spit.

    If I take the plugs out and lay them on the cylinder heads, I get a spark at both plugs and after some attempts to start, the tops of the pistons are wet with fuel, so I know it’s getting fuel through.

    This is why I suspect the ignition coil. In the past I have known coils to supply a spark with the plugs out, but when they are installed they can’t cope with firing under compression.

    I just wondered if anyone has had a similar issue.

    #13056
    lonesome
    Spectator

    Just to second what Mike wrote, and could I also suggest heating the plugs over a gas hob before trying again.

    Unfortunately, the coils are also a bit weak, and they do fail, the difficult bit is that it ran, then stopped, suggesting that they’re ok.

    It actually needs very little choke once it’s running, and will quickly die if you leave it to idle on full choke (I checked with mine this afternoon). It’s best warmed up by sitting like a lemon holding the throttle open. On mine, from starting from cold ( first time since November, tho it started 2nd kick on 3/4 choke) it took over 5 minutes before I could let go of the throttle.

    #13063
    stuartbuckle
    Participant

    Thanks LONESOME and MIKEONABIKE,

    I have tried it on the kickstart with the battery fully charged….nothing. This week I have ordered a new ignition coil and some new NGK plug caps which I can fit at the weekend. So I’ll give that a try.

    #13067
    stuartbuckle
    Participant

    OK, the new ignition coil and plug caps arrived. Wrong coil. Still, I tried something else. I found that all of a sudden, I have no spark at either the plugs or when I flick the points open. This was all working previously.

    So, I ran a direct feed from the battery live to the coil input and BINGO! It started FIRST KICK.

    So the present situation is that the engine will not crank on the electric starter, there is no ignition feed. No power at the starter solenoid apart from the main, thick battery cable.

    I’m thinking I might have to investigate the ignition switch area. Maybe a loose/bad connection?

    It had a new ignition switch fitted a short while ago and I also fitted a new headlamp. So maybe the switch is partially unplugged or I may have disturbed some wiring connections in that area.

    I’m checking today.

    #13070
    Mikeonabike
    Participant

    Should not be to difficult to find as it is a 100% fail, intermitant fauls are more difficult to find, probably just a block conecter come apart.
    I didnt think it would be the coils as I have never had one fail in the 40 years I have been riding bikes, never had to buy new clutch plates either though I have had to put washers under the springs on race bikes.
    Hope you get it sorted easily.

    #13058
    lonesome
    Spectator

    OK, somewhere near the seat lock is a single white wire on a connector going into the electric panel. This connector can be a pain in the arse and falls out at the least opportunity. I can’t take a pic as my bikes all wrapped up ready for rain, but it’s easy to check if you know where it is. Anyhow, it’s the main ignition feed and has left me at the side of the road loads of times.

    #13061
    Michael
    Participant

    This cable ?
    Very right hand side, connected to the red covered battery plus cable ?

    #13059
    lonesome
    Spectator

    Exactly. Thanks Micheal.

    #13068
    stuartbuckle
    Participant

    Thanks for all the help and tips guys. However, I had somebody come and buy the bike from me at the weekend, so it’s now gone. As I mentioned, it did run with a live to the ignition coil, so I think it probably is a loose/bad connection somewhere, but the new owner will be sorting it out.

    Now I just have my 2014 Bonneville T100.

    I am 64 now and am a bit tired of tinkering with older bikes, besides, the old joints/muscles ache after grovelling around on the floor or being bent over or crouched down for too long.

    So I’ve copped-out and it’s the easy life for me. Dealer service once a year and that’s it.

    Thanks again.

    Stuart

    #13062
    Michael
    Participant

    Hi Stuart,

    I can understand your situation.
    To bad that you have sold the Kawasaki.

    You may contact the buyer again and give him a hint, that this forum exists and he is more than welcome to join.

    All the best to you and have fun riding your bike 😉

    Cheers, Michael (from Germany)

    #13069
    stuartbuckle
    Participant

    THE ANSWER !!

    It was a problem with the kill switch.

    The guy who bought the bike traced the fault.

    Thanks for all comments, hints and tips.

    It is now sorted.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.

Share this